FTDI FT232RL Arduino Com Ports All Used

Feb 14, 2015 at 12:09 AM
GhostBuster did not work for me on a Windows 7 64 bit and Windows Vista 32 bit. When I finished adding the devices and removing them, Windows would get stuck on loading the driver for the USB Serial Port.

I had to follow the instructions on:

Specifically, I had to delete the serial port keys in:
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Ports

Feb 14, 2015 at 10:29 AM

Can you explain what you did?

In Ghostbuster you have to mark devices or classes as removable when ghosted (right click a device in the list). If you do the colors change. Then when you press the remove ghosts button it will try to remove them by calling the Windows uninstall API. Some devices (marked as services) I exclude being to risky to delete.

If this last part fails (in which case uninstalling it in the device manager will probably also fail), Ghostbuster cannot remove the device either.

It is also possible that the kind of device you use is made up of several drives (I use an mBed controller and i's composed of a Serial Port, a Flash Drive and a Debugging Device). But even that removes just fine.

Feb 15, 2015 at 3:03 AM
Yes, I selected the offending USB Serial Ports and USB Serial Converters that were related to my FTDI FT232RL USB to Serial Converters. I chose Device and then Remove. All offending items showed to be removed after a refresh, but the driver loading would get stuck on the USB Serial Port driver load and would timeout after many minutes.

I had to remove the offending serial com port entries listed under HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Ports.
Feb 15, 2015 at 3:07 PM

Can you please try if the windows device manager also has problems removing the device?

I've seen some of these problematic devices in the past and every time both the device manager and Ghostbuster has the same problems.

I never found the actual cause (most likely a corrupted installation) but a re-install most of the time helped (do not forget to remove the oem*.inf file in \windows\inf that belongs to this device too).

Feb 15, 2015 at 3:12 PM
Please understand that I have already resolved my issue by removing the serial port entries in:
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Ports

So, I ran Ghostbuster and then deleted the entries in the registry. This worked on two separate computers.

Sorry I can't be of more assistance, but I must move on.

Thanks for your utility!